[jira] Created: (TIKA-246) Dependency to Log4j

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[jira] Created: (TIKA-246) Dependency to Log4j

Tim Allison (Jira)
Dependency to Log4j
-------------------

                 Key: TIKA-246
                 URL: https://issues.apache.org/jira/browse/TIKA-246
             Project: Tika
          Issue Type: Improvement
          Components: packaging
    Affects Versions: 0.3
         Environment: All
            Reporter: Karl Heinz Marbaise
            Priority: Trivial


I have observed that the log4j dependency in Tika is on release 1.2.14 (compile), but for the poi-scratchpad it's 1.2.13 (compile)..May it's possible to change to 1.2.13 to reduce the number of dependencies.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply | Threaded
Open this post in threaded view
|

[jira] Commented: (TIKA-246) Dependency to Log4j

Tim Allison (Jira)

    [ https://issues.apache.org/jira/browse/TIKA-246?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12739782#action_12739782 ]

Jukka Zitting commented on TIKA-246:
------------------------------------

I'm not sure I understand the problem. If you use Maven, it'll automatically select just a single version of a dependency.

> Dependency to Log4j
> -------------------
>
>                 Key: TIKA-246
>                 URL: https://issues.apache.org/jira/browse/TIKA-246
>             Project: Tika
>          Issue Type: Improvement
>          Components: packaging
>    Affects Versions: 0.3
>         Environment: All
>            Reporter: Karl Heinz Marbaise
>            Priority: Trivial
>
> I have observed that the log4j dependency in Tika is on release 1.2.14 (compile), but for the poi-scratchpad it's 1.2.13 (compile)..May it's possible to change to 1.2.13 to reduce the number of dependencies.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply | Threaded
Open this post in threaded view
|

[jira] Resolved: (TIKA-246) Dependency to Log4j

Tim Allison (Jira)
In reply to this post by Tim Allison (Jira)

     [ https://issues.apache.org/jira/browse/TIKA-246?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jukka Zitting resolved TIKA-246.
--------------------------------

    Resolution: Invalid
      Assignee: Jukka Zitting

Resolving as Invalid based on my earlier comment.

> Dependency to Log4j
> -------------------
>
>                 Key: TIKA-246
>                 URL: https://issues.apache.org/jira/browse/TIKA-246
>             Project: Tika
>          Issue Type: Improvement
>          Components: packaging
>    Affects Versions: 0.3
>         Environment: All
>            Reporter: Karl Heinz Marbaise
>            Assignee: Jukka Zitting
>            Priority: Trivial
>
> I have observed that the log4j dependency in Tika is on release 1.2.14 (compile), but for the poi-scratchpad it's 1.2.13 (compile)..May it's possible to change to 1.2.13 to reduce the number of dependencies.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.