multicore can't find the data directories

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

multicore can't find the data directories

Andrew Nagy-2
I am trying to setup a multicore system implementation.  I just upgraded to today's snapshot and have converted my multicore.xml to solr.war and I also changed the xml to match the new schema.  However, now that I have done that, Solr is not finding my data directory.  With the use of multicore - does each core have its own data directory?

I have the following setup:

solr/core0/conf
solr/core1/conf
solr/solr.xml

When I look at the admin (http://localhost:8080/solr/core0/admin/stats.jsp) it shows the following:
readerDir : org.apache.lucene.store.FSDirectory@/usr/local/solr/data/index<mailto:org.apache.lucene.store.FSDirectory@/usr/local/solr/data/index>

and numDocs is reporting 0.

However I have my index with plenty of records located in solr/core0/data/index

Is Solr looking in the wrong directory, or do I have my index in the wrong place?

Thanks
Andrew



Reply | Threaded
Open this post in threaded view
|

RE: multicore can't find the data directories

Andrew Nagy-2
Nevermind - sorry.  The data directory in my solrconfig.xml was not changed to the correct path.  Now it's alive!

Andrew

> -----Original Message-----
> From: Andrew Nagy [mailto:[hidden email]]
> Sent: Wednesday, August 13, 2008 12:13 PM
> To: [hidden email]
> Subject: multicore can't find the data directories
>
> I am trying to setup a multicore system implementation.  I just
> upgraded to today's snapshot and have converted my multicore.xml to
> solr.war and I also changed the xml to match the new schema.  However,
> now that I have done that, Solr is not finding my data directory.  With
> the use of multicore - does each core have its own data directory?
>
> I have the following setup:
>
> solr/core0/conf
> solr/core1/conf
> solr/solr.xml
>
> When I look at the admin
> (http://localhost:8080/solr/core0/admin/stats.jsp) it shows the
> following:
> readerDir :
> org.apache.lucene.store.FSDirectory@/usr/local/solr/data/index<mailto:o
> rg.apache.lucene.store.FSDirectory@/usr/local/solr/data/index>
>
> and numDocs is reporting 0.
>
> However I have my index with plenty of records located in
> solr/core0/data/index
>
> Is Solr looking in the wrong directory, or do I have my index in the
> wrong place?
>
> Thanks
> Andrew
>
>