refresh solr stats on plugin/stats

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

refresh solr stats on plugin/stats

Lorenzo Fundaró
Hello folks,

when selecting a core, under the tab Plugin/Stats, if I click on "Refresh
Values" I get redirected to the dashboard, is this the right behaviour ? or
is it a bug ? I think it should stay on the page and refresh the stats. I
am using solr 5.0.0, but I found the same behaviour on 5.3.0.

Cheers !

--

--
Lorenzo Fundaro
Backend Engineer
E-Mail: [hidden email]

Fax       + 49 - (0)30 - 25 76 08 52
Tel        + 49 - (0)179 - 51 10 982

DaWanda GmbH
Windscheidstraße 18
10627 Berlin

Geschäftsführer: Claudia Helming, Michael Pütz
Amtsgericht Charlottenburg HRB 104695 B
Reply | Threaded
Open this post in threaded view
|

Re: refresh solr stats on plugin/stats

Shawn Heisey-2
On 9/22/2015 7:42 AM, Lorenzo Fundaró wrote:
> when selecting a core, under the tab Plugin/Stats, if I click on "Refresh
> Values" I get redirected to the dashboard, is this the right behaviour ? or
> is it a bug ? I think it should stay on the page and refresh the stats. I
> am using solr 5.0.0, but I found the same behaviour on 5.3.0.

Looks like a browser-related issue.  I tried 5.2.1 and 5.3.0 with both
Chrome and Firefox, it worked with no problem.  Then I tried it with
Microsoft Edge.  It behaved exactly as you said.

I then tried it in IE11.  It behaves even worse than Edge ... I get a
popup saying "404 Not Found get".

Getting Microsoft browsers to work right in web interfaces while
maintaining compatibility with other browsers is always challenging.  I
recommend using something else.

The new AngularJS admin UI, which is slated to become the default fairly
soon, seems to work correctly in Microsoft browsers.

I opened a bug issue for the problem:

https://issues.apache.org/jira/browse/SOLR-8084

Thanks,
Shawn

Reply | Threaded
Open this post in threaded view
|

Re: refresh solr stats on plugin/stats

Stefan Matheis-3
In reply to this post by Lorenzo Fundaró
Hi Lorenzo  

That is neither supposed to happen on 5.0.0 nor 5.3.0 - no matter if you're
using the current or the new admin ui (talking about the angular.js app)

Are you able to have a look at your browser console while that happens?
Do you get error messages? any other output?

What should happen is that an overlay is opening showing a spinner and
"waiting for changes" as long as this modal overlay is open. as soon as  
you hit "stop & show changes" it should close and reload the view, telling
you which handlers changed between the time when you started watching
and stopped it.

-Stefan  


On Tuesday, September 22, 2015 at 3:42 PM, Lorenzo Fundaró wrote:

> Hello folks,
>  
> when selecting a core, under the tab Plugin/Stats, if I click on "Refresh
> Values" I get redirected to the dashboard, is this the right behaviour ? or
> is it a bug ? I think it should stay on the page and refresh the stats. I
> am using solr 5.0.0, but I found the same behaviour on 5.3.0.
>  
> Cheers !
>  
> --  
>  
> --  
> Lorenzo Fundaro
> Backend Engineer
> E-Mail: [hidden email] (mailto:[hidden email])
>  
> Fax + 49 - (0)30 - 25 76 08 52
> Tel + 49 - (0)179 - 51 10 982
>  
> DaWanda GmbH
> Windscheidstraße 18
> 10627 Berlin
>  
> Geschäftsführer: Claudia Helming, Michael Pütz
> Amtsgericht Charlottenburg HRB 104695 B
>  
>  


Reply | Threaded
Open this post in threaded view
|

Re: refresh solr stats on plugin/stats

Stefan Matheis-3
In reply to this post by Shawn Heisey-2
dang, sounds like Shawn is right on .. Lorenzo can you tell us more about  
the system you're using including browser specifics?

-Stefan  


On Tuesday, September 22, 2015 at 4:17 PM, Shawn Heisey wrote:

> On 9/22/2015 7:42 AM, Lorenzo Fundaró wrote:
> > when selecting a core, under the tab Plugin/Stats, if I click on "Refresh
> > Values" I get redirected to the dashboard, is this the right behaviour ? or
> > is it a bug ? I think it should stay on the page and refresh the stats. I
> > am using solr 5.0.0, but I found the same behaviour on 5.3.0.
> >  
>  
>  
> Looks like a browser-related issue. I tried 5.2.1 and 5.3.0 with both
> Chrome and Firefox, it worked with no problem. Then I tried it with
> Microsoft Edge. It behaved exactly as you said.
>  
> I then tried it in IE11. It behaves even worse than Edge ... I get a
> popup saying "404 Not Found get".
>  
> Getting Microsoft browsers to work right in web interfaces while
> maintaining compatibility with other browsers is always challenging. I
> recommend using something else.
>  
> The new AngularJS admin UI, which is slated to become the default fairly
> soon, seems to work correctly in Microsoft browsers.
>  
> I opened a bug issue for the problem:
>  
> https://issues.apache.org/jira/browse/SOLR-8084
>  
> Thanks,
> Shawn
>  
>  


Reply | Threaded
Open this post in threaded view
|

Re: refresh solr stats on plugin/stats

Shawn Heisey-2
In reply to this post by Shawn Heisey-2
On 9/22/2015 8:17 AM, Shawn Heisey wrote:
> On 9/22/2015 7:42 AM, Lorenzo Fundaró wrote:
>> when selecting a core, under the tab Plugin/Stats, if I click on "Refresh
>> Values" I get redirected to the dashboard, is this the right behaviour ? or
>> is it a bug ? I think it should stay on the page and refresh the stats. I
>> am using solr 5.0.0, but I found the same behaviour on 5.3.0.
>
> Looks like a browser-related issue.  I tried 5.2.1 and 5.3.0 with both
> Chrome and Firefox, it worked with no problem.  Then I tried it with
> Microsoft Edge.  It behaved exactly as you said.

Followup -- I double-checked one more time and found that I had
forgotten to test one combination.  Chrome behaves the same as Edge.
I've updated the issue.

Thanks,
Shawn

Reply | Threaded
Open this post in threaded view
|

Re: refresh solr stats on plugin/stats

Lorenzo Fundaró
In reply to this post by Stefan Matheis-3
@Shawn, here's my browser config:

Google Chrome45.0.2454.93 (Official Build) (64-bit)Revision
ba1cb72081c2c07e4b689082852b1463fbca95f5-refs/branch-heads/2454@{#466}OSMac
OS X Blink537.36 (@202161)JavaScriptV8 4.5.103.31Flash18.0.0.232User
AgentMozilla/5.0
(Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko)
Chrome/45.0.2454.93 Safari/537.36Command Line/Applications/Google
Chrome.app/Contents/MacOS/Google Chrome --enable-avfoundation
--enable-avfoundation --flag-switches-begin --flag-switches-end



On 22 September 2015 at 16:26, Stefan Matheis <[hidden email]> wrote:

> dang, sounds like Shawn is right on .. Lorenzo can you tell us more about
> the system you're using including browser specifics?
>
> -Stefan
>
>
> On Tuesday, September 22, 2015 at 4:17 PM, Shawn Heisey wrote:
>
> > On 9/22/2015 7:42 AM, Lorenzo Fundaró wrote:
> > > when selecting a core, under the tab Plugin/Stats, if I click on
> "Refresh
> > > Values" I get redirected to the dashboard, is this the right behaviour
> ? or
> > > is it a bug ? I think it should stay on the page and refresh the
> stats. I
> > > am using solr 5.0.0, but I found the same behaviour on 5.3.0.
> > >
> >
> >
> > Looks like a browser-related issue. I tried 5.2.1 and 5.3.0 with both
> > Chrome and Firefox, it worked with no problem. Then I tried it with
> > Microsoft Edge. It behaved exactly as you said.
> >
> > I then tried it in IE11. It behaves even worse than Edge ... I get a
> > popup saying "404 Not Found get".
> >
> > Getting Microsoft browsers to work right in web interfaces while
> > maintaining compatibility with other browsers is always challenging. I
> > recommend using something else.
> >
> > The new AngularJS admin UI, which is slated to become the default fairly
> > soon, seems to work correctly in Microsoft browsers.
> >
> > I opened a bug issue for the problem:
> >
> > https://issues.apache.org/jira/browse/SOLR-8084
> >
> > Thanks,
> > Shawn
> >
> >
>
>
>


--

--
Lorenzo Fundaro
Backend Engineer
E-Mail: [hidden email]

Fax       + 49 - (0)30 - 25 76 08 52
Tel        + 49 - (0)179 - 51 10 982

DaWanda GmbH
Windscheidstraße 18
10627 Berlin

Geschäftsführer: Claudia Helming, Michael Pütz
Amtsgericht Charlottenburg HRB 104695 B
Reply | Threaded
Open this post in threaded view
|

Re: refresh solr stats on plugin/stats

Lorenzo Fundaró
@Stefan

I checked the browser console, no errors, and a bunch of requests doing
GET's either froms scripts, xhr, and some of them getting 200 and other
304's.

I am able to see the overlay, but this is when a click on "*watch changes*",
this feature actually works as expected.

It is the "Refresh values" that's  not showing any overlay or anything at
all but it's redirecting to dashboard instead.

cheers !

On 22 September 2015 at 16:35, Lorenzo Fundaró <
[hidden email]> wrote:

> @Shawn, here's my browser config:
>
> Google Chrome45.0.2454.93 (Official Build) (64-bit)Revision
> ba1cb72081c2c07e4b689082852b1463fbca95f5-refs/branch-heads/2454@{#466}OSMac
> OS X Blink537.36 (@202161)JavaScriptV8 4.5.103.31Flash18.0.0.232User AgentMozilla/5.0
> (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko)
> Chrome/45.0.2454.93 Safari/537.36Command Line/Applications/Google
> Chrome.app/Contents/MacOS/Google Chrome --enable-avfoundation
> --enable-avfoundation --flag-switches-begin --flag-switches-end
>
>
>
> On 22 September 2015 at 16:26, Stefan Matheis <[hidden email]> wrote:
>
>> dang, sounds like Shawn is right on .. Lorenzo can you tell us more about
>> the system you're using including browser specifics?
>>
>> -Stefan
>>
>>
>> On Tuesday, September 22, 2015 at 4:17 PM, Shawn Heisey wrote:
>>
>> > On 9/22/2015 7:42 AM, Lorenzo Fundaró wrote:
>> > > when selecting a core, under the tab Plugin/Stats, if I click on
>> "Refresh
>> > > Values" I get redirected to the dashboard, is this the right
>> behaviour ? or
>> > > is it a bug ? I think it should stay on the page and refresh the
>> stats. I
>> > > am using solr 5.0.0, but I found the same behaviour on 5.3.0.
>> > >
>> >
>> >
>> > Looks like a browser-related issue. I tried 5.2.1 and 5.3.0 with both
>> > Chrome and Firefox, it worked with no problem. Then I tried it with
>> > Microsoft Edge. It behaved exactly as you said.
>> >
>> > I then tried it in IE11. It behaves even worse than Edge ... I get a
>> > popup saying "404 Not Found get".
>> >
>> > Getting Microsoft browsers to work right in web interfaces while
>> > maintaining compatibility with other browsers is always challenging. I
>> > recommend using something else.
>> >
>> > The new AngularJS admin UI, which is slated to become the default fairly
>> > soon, seems to work correctly in Microsoft browsers.
>> >
>> > I opened a bug issue for the problem:
>> >
>> > https://issues.apache.org/jira/browse/SOLR-8084
>> >
>> > Thanks,
>> > Shawn
>> >
>> >
>>
>>
>>
>
>
> --
>
> --
> Lorenzo Fundaro
> Backend Engineer
> E-Mail: [hidden email]
>
> Fax       + 49 - (0)30 - 25 76 08 52
> Tel        + 49 - (0)179 - 51 10 982
>
> DaWanda GmbH
> Windscheidstraße 18
> 10627 Berlin
>
> Geschäftsführer: Claudia Helming, Michael Pütz
> Amtsgericht Charlottenburg HRB 104695 B
>



--

--
Lorenzo Fundaro
Backend Engineer
E-Mail: [hidden email]

Fax       + 49 - (0)30 - 25 76 08 52
Tel        + 49 - (0)179 - 51 10 982

DaWanda GmbH
Windscheidstraße 18
10627 Berlin

Geschäftsführer: Claudia Helming, Michael Pütz
Amtsgericht Charlottenburg HRB 104695 B
Reply | Threaded
Open this post in threaded view
|

Re: refresh solr stats on plugin/stats

Stefan Matheis-3
Thanks Lorenzo  

Don't know why, but i didn't get it while i've first read your mail. pretty sure
that worked earlier, the fix itself should be rather easy - i'll attached a patch
to Shawn's Ticket.

What's supposed to happen (in the current ui): reload the current address,
which is the same as you'd hit F5 or CTRL+R (depending on your OS) ...
nothing special :)

-Stefan  


On Tuesday, September 22, 2015 at 4:43 PM, Lorenzo Fundaró wrote:

> @Stefan
>  
> I checked the browser console, no errors, and a bunch of requests doing
> GET's either froms scripts, xhr, and some of them getting 200 and other
> 304's.
>  
> I am able to see the overlay, but this is when a click on "*watch changes*",
> this feature actually works as expected.
>  
> It is the "Refresh values" that's not showing any overlay or anything at
> all but it's redirecting to dashboard instead.
>  
> cheers !
>  
> On 22 September 2015 at 16:35, Lorenzo Fundaró <
> [hidden email] (mailto:[hidden email])> wrote:
>  
> > @Shawn, here's my browser config:
> >  
> > Google Chrome45.0.2454.93 (Official Build) (64-bit)Revision
> > ba1cb72081c2c07e4b689082852b1463fbca95f5-refs/branch-heads/2454@{#466}OSMac
> > OS X Blink537.36 (@202161)JavaScriptV8 4.5.103.31Flash18.0.0.232User AgentMozilla/5.0
> > (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko)
> > Chrome/45.0.2454.93 Safari/537.36Command Line/Applications/Google
> > Chrome.app/Contents/MacOS/Google Chrome --enable-avfoundation
> > --enable-avfoundation --flag-switches-begin --flag-switches-end
> >  
> >  
> >  
> > On 22 September 2015 at 16:26, Stefan Matheis <[hidden email] (mailto:[hidden email])> wrote:
> >  
> > > dang, sounds like Shawn is right on .. Lorenzo can you tell us more about
> > > the system you're using including browser specifics?
> > >  
> > > -Stefan
> > >  
> > >  
> > > On Tuesday, September 22, 2015 at 4:17 PM, Shawn Heisey wrote:
> > >  
> > > > On 9/22/2015 7:42 AM, Lorenzo Fundaró wrote:
> > > > > when selecting a core, under the tab Plugin/Stats, if I click on
> > > >  
> > > >  
> > >  
> > > "Refresh
> > > > > Values" I get redirected to the dashboard, is this the right
> > > >  
> > >  
> > > behaviour ? or
> > > > > is it a bug ? I think it should stay on the page and refresh the
> > > >  
> > >  
> > > stats. I
> > > > > am using solr 5.0.0, but I found the same behaviour on 5.3.0.
> > > >  
> > > >  
> > > >  
> > > > Looks like a browser-related issue. I tried 5.2.1 and 5.3.0 with both
> > > > Chrome and Firefox, it worked with no problem. Then I tried it with
> > > > Microsoft Edge. It behaved exactly as you said.
> > > >  
> > > > I then tried it in IE11. It behaves even worse than Edge ... I get a
> > > > popup saying "404 Not Found get".
> > > >  
> > > > Getting Microsoft browsers to work right in web interfaces while
> > > > maintaining compatibility with other browsers is always challenging. I
> > > > recommend using something else.
> > > >  
> > > > The new AngularJS admin UI, which is slated to become the default fairly
> > > > soon, seems to work correctly in Microsoft browsers.
> > > >  
> > > > I opened a bug issue for the problem:
> > > >  
> > > > https://issues.apache.org/jira/browse/SOLR-8084
> > > >  
> > > > Thanks,
> > > > Shawn
> > > >  
> > >  
> > >  
> >  
> >  
> >  
> > --
> >  
> > --
> > Lorenzo Fundaro
> > Backend Engineer
> > E-Mail: [hidden email] (mailto:[hidden email])
> >  
> > Fax + 49 - (0)30 - 25 76 08 52
> > Tel + 49 - (0)179 - 51 10 982
> >  
> > DaWanda GmbH
> > Windscheidstraße 18
> > 10627 Berlin
> >  
> > Geschäftsführer: Claudia Helming, Michael Pütz
> > Amtsgericht Charlottenburg HRB 104695 B
> >  
>  
>  
>  
>  
> --  
>  
> --  
> Lorenzo Fundaro
> Backend Engineer
> E-Mail: [hidden email] (mailto:[hidden email])
>  
> Fax + 49 - (0)30 - 25 76 08 52
> Tel + 49 - (0)179 - 51 10 982
>  
> DaWanda GmbH
> Windscheidstraße 18
> 10627 Berlin
>  
> Geschäftsführer: Claudia Helming, Michael Pütz
> Amtsgericht Charlottenburg HRB 104695 B
>  
>