solrcloud nodes registering as 127.0.1.1

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

solrcloud nodes registering as 127.0.1.1

Matteo Grolla
Hi,
        hope someone can help me troubleshoot this issue.
I'm trying to setup a solrcloud cluster with

-zookeeper on 192.168.1.8 (osx mac)
-solr1 on 192.168.1.10 (virtualized ubuntu running on mac)
-solr2 on 192.168.1.3 (ubuntu on another pc)

the problem is that both nodes register on zookeeper as 127.0.1.1 so they appear as the same node
here's a message from solr log

5962 [zkCallback-2-thread-1] INFO  org.apache.solr.cloud.DistributedQueue  – LatchChildWatcher fired on path: /overseer/queue state: SyncConnected type NodeChildrenChanged
5965 [OverseerStateUpdate-93130698829725696-127.0.1.1:8983_solr-n_0000000000] INFO  org.apache.solr.cloud.Overseer  – Update state numShards=2 message={
  "operation":"state",
  "core_node_name":"core_node1",
  "numShards":"2",
  "shard":"shard1",
  "roles":null,
  "state":"active",
  "core":"collection1",
  "collection":"collection1",
  "node_name":"127.0.1.1:8983_solr",
  "base_url":"http://127.0.1.1:8983/solr"}


I'm able to run the cluster if I change jetty.port to one of the nodes, but I'd really like some help troubleshooting this issue.

Thanks
Reply | Threaded
Open this post in threaded view
|

Re: solrcloud nodes registering as 127.0.1.1

Matteo Grolla
Solved!
        ubuntu has an entry like this in /etc/hosts

127.0.1.1 <hostname>

to properly run solrcloud one must substitute 127.0.1.1 with a real (possibly permanent) ip address



Il giorno 12/gen/2015, alle ore 12:47, Matteo Grolla ha scritto:

> Hi,
> hope someone can help me troubleshoot this issue.
> I'm trying to setup a solrcloud cluster with
>
> -zookeeper on 192.168.1.8 (osx mac)
> -solr1 on 192.168.1.10 (virtualized ubuntu running on mac)
> -solr2 on 192.168.1.3 (ubuntu on another pc)
>
> the problem is that both nodes register on zookeeper as 127.0.1.1 so they appear as the same node
> here's a message from solr log
>
> 5962 [zkCallback-2-thread-1] INFO  org.apache.solr.cloud.DistributedQueue  – LatchChildWatcher fired on path: /overseer/queue state: SyncConnected type NodeChildrenChanged
> 5965 [OverseerStateUpdate-93130698829725696-127.0.1.1:8983_solr-n_0000000000] INFO  org.apache.solr.cloud.Overseer  – Update state numShards=2 message={
>  "operation":"state",
>  "core_node_name":"core_node1",
>  "numShards":"2",
>  "shard":"shard1",
>  "roles":null,
>  "state":"active",
>  "core":"collection1",
>  "collection":"collection1",
>  "node_name":"127.0.1.1:8983_solr",
>  "base_url":"http://127.0.1.1:8983/solr"}
>
>
> I'm able to run the cluster if I change jetty.port to one of the nodes, but I'd really like some help troubleshooting this issue.
>
> Thanks

Reply | Threaded
Open this post in threaded view
|

Re: solrcloud nodes registering as 127.0.1.1

Michael Della Bitta-2
Another way of doing it is by setting the -Dhost=$hostname parameter when
you start Solr.

Michael Della Bitta

Senior Software Engineer

o: +1 646 532 3062

appinions inc.

“The Science of Influence Marketing”

18 East 41st Street

New York, NY 10017

t: @appinions <https://twitter.com/Appinions> | g+:
plus.google.com/appinions
<https://plus.google.com/u/0/b/112002776285509593336/112002776285509593336/posts>
w: appinions.com <http://www.appinions.com/>

On Mon, Jan 12, 2015 at 7:15 AM, Matteo Grolla <[hidden email]>
wrote:

> Solved!
>         ubuntu has an entry like this in /etc/hosts
>
> 127.0.1.1       <hostname>
>
> to properly run solrcloud one must substitute 127.0.1.1 with a real
> (possibly permanent) ip address
>
>
>
> Il giorno 12/gen/2015, alle ore 12:47, Matteo Grolla ha scritto:
>
> > Hi,
> >       hope someone can help me troubleshoot this issue.
> > I'm trying to setup a solrcloud cluster with
> >
> > -zookeeper on 192.168.1.8             (osx mac)
> > -solr1 on 192.168.1.10                (virtualized ubuntu running on mac)
> > -solr2 on 192.168.1.3         (ubuntu on another pc)
> >
> > the problem is that both nodes register on zookeeper as 127.0.1.1 so
> they appear as the same node
> > here's a message from solr log
> >
> > 5962 [zkCallback-2-thread-1] INFO
> org.apache.solr.cloud.DistributedQueue  – LatchChildWatcher fired on path:
> /overseer/queue state: SyncConnected type NodeChildrenChanged
> > 5965
> [OverseerStateUpdate-93130698829725696-127.0.1.1:8983_solr-n_0000000000]
> INFO  org.apache.solr.cloud.Overseer  – Update state numShards=2 message={
> >  "operation":"state",
> >  "core_node_name":"core_node1",
> >  "numShards":"2",
> >  "shard":"shard1",
> >  "roles":null,
> >  "state":"active",
> >  "core":"collection1",
> >  "collection":"collection1",
> >  "node_name":"127.0.1.1:8983_solr",
> >  "base_url":"http://127.0.1.1:8983/solr"}
> >
> >
> > I'm able to run the cluster if I change jetty.port to one of the nodes,
> but I'd really like some help troubleshooting this issue.
> >
> > Thanks
>
>