which version of lucene do you recommend

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

which version of lucene do you recommend

Christian Reuschling-2
in the past, I made really good experiences with the svn versions of lucene -
I never had problems, and everything feeled stable.

Currently, I get unexpected exceptions from time to time:

java.lang.RuntimeException: after flush: fdx size mismatch: 1 docs vs 0 length in bytes of _3g6n.fdx
        at org.apache.lucene.index.StoredFieldsWriter.closeDocStore(StoredFieldsWriter.java:94)
        at org.apache.lucene.index.DocFieldConsumers.closeDocStore(DocFieldConsumers.java:83)
        at org.apache.lucene.index.DocFieldProcessor.closeDocStore(DocFieldProcessor.java:47)
        at org.apache.lucene.index.DocumentsWriter.closeDocStore(DocumentsWriter.java:367)
        at org.apache.lucene.index.DocumentsWriter.flush(DocumentsWriter.java:567)
        at org.apache.lucene.index.IndexWriter.doFlush(IndexWriter.java:3618)
        at org.apache.lucene.index.IndexWriter.flush(IndexWriter.java:3527)
        at org.apache.lucene.index.IndexWriter.closeInternal(IndexWriter.java:1709)
        at org.apache.lucene.index.IndexWriter.close(IndexWriter.java:1674)
        at org.apache.lucene.index.IndexWriter.close(IndexWriter.java:1648)

I'm not shure how I should proceed now. Yesterday I switched to the new svn build, but no
change. Can you recommend the svn version, or would you say I should switch back to the
release?


Thanks in advance

Christian


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: which version of lucene do you recommend

Michael McCandless-2

We try very hard to keep Lucene's trunk usable, but, sneaky things do  
slip in from time to time so you certainly have to do your own  
testing.  And if you hit problems, be sure to raise them!

Which exact JRE version are you using?  It could be you are hitting  
the Sun JRE bug described here:

      https://issues.apache.org/jira/browse/LUCENE-1282

in which case you either have to downgrade or upgrade your JRE.

Mike

Christian Reuschling wrote:

> in the past, I made really good experiences with the svn versions of  
> lucene -
> I never had problems, and everything feeled stable.
>
> Currently, I get unexpected exceptions from time to time:
>
> java.lang.RuntimeException: after flush: fdx size mismatch: 1 docs  
> vs 0 length in bytes of _3g6n.fdx
> at  
> org
> .apache
> .lucene
> .index.StoredFieldsWriter.closeDocStore(StoredFieldsWriter.java:94)
> at  
> org
> .apache
> .lucene.index.DocFieldConsumers.closeDocStore(DocFieldConsumers.java:
> 83)
> at  
> org
> .apache
> .lucene.index.DocFieldProcessor.closeDocStore(DocFieldProcessor.java:
> 47)
> at  
> org
> .apache
> .lucene.index.DocumentsWriter.closeDocStore(DocumentsWriter.java:367)
> at  
> org.apache.lucene.index.DocumentsWriter.flush(DocumentsWriter.java:
> 567)
> at org.apache.lucene.index.IndexWriter.doFlush(IndexWriter.java:3618)
> at org.apache.lucene.index.IndexWriter.flush(IndexWriter.java:3527)
> at  
> org.apache.lucene.index.IndexWriter.closeInternal(IndexWriter.java:
> 1709)
> at org.apache.lucene.index.IndexWriter.close(IndexWriter.java:1674)
> at org.apache.lucene.index.IndexWriter.close(IndexWriter.java:1648)
>
> I'm not shure how I should proceed now. Yesterday I switched to the  
> new svn build, but no
> change. Can you recommend the svn version, or would you say I should  
> switch back to the
> release?
>
>
> Thanks in advance
>
> Christian
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]